Inbox Performance Degradation

Incident Report for Zowie Region EU1

Resolved

The incident has been resolved, and Inbox functions should now be running smoothly.
Posted Aug 05, 2026 - 11:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2026 - 10:53 UTC

Investigating

We are currently checking into an Inbox issue that is affecting this region and potentially causing degraded performance for agents.
Posted Aug 05, 2026 - 09:31 UTC
This incident affected: Inbox.