Inbox Assignment Degradation

Incident Report for Zowie Region EU1

Resolved

The incident has been resolved.
Posted Jun 30, 2026 - 07:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 07:20 UTC

Identified

The issue has been identified and we are working on a resolution.
Posted Jun 30, 2026 - 06:49 UTC

Investigating

We are currently investigating an issue causing threads not to be automatically assigned to agents in the Inbox.
Posted Jun 30, 2026 - 06:32 UTC
This incident affected: Inbox.